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Swiss Pairs using SwissPairsScorer with Bridgemates 
 
1. OVERVIEW 
 
1.1 Tables 
The program allows the event to be organised as either one section with tables A1… or as a multi-
section event with tables A1…, B1… etc.  Each section can have up to 100 tables so multi-section 
events are likely to be extremely rare. 
 
1.2 Program Constraints 
The current program limits are: - 

 Tables   100 in each section 
 Sections  40 
 Rounds   15 
 Sessions  12 
 Boards per Round 12 
 Boards per Session 50 

The only constraint which is likely to have any effect is the limit of 50 boards per session. 
 
1.3 Sessions 
At the start of each session, boards are numbered from 1.  Scores & round numbers are carried 
forward from one session to the next.  (One future change will be removal of the restriction that every 
session starts with Board 1.  This will allow pre tournament duplimating more flexibility.) 

If the total boards in the event do not exceed 50, then it is possible to set up the event as a single 
session.  However, it is likely that the highest numbered physical board number will be 32, while 
board numbers up to 50 will be displayed on the bridgemates.  This can be overcome by using 
numbered labels on the boards, providing personal score-sheets with boards over 32 numbered as 
1/33, 2/34 etc., or by simply telling the players to add 32 to the physical board number. 
The alternative is to set up the program as a multi-session event so that no renumbering of boards is 
required.  If the event has more than 50 boards, you have no choice; it will have to be multi-session.  
It also makes sense to try and structure the event sessions round meal breaks etc 
This has implications for the preparation of boards 
For example, 
8 x 6 board rounds with meal break between rounds 5 & 6 
 Session 1: 5 rounds (bds 1-30); Session 2: 3 rounds (bds 1-18) 
9 x 8 board rounds with breaks after rounds 4 & 6 
 Session 1: 3 rounds (bds 1-24): Session 2: 3 rounds (bds 1-24): Session 3: 3 rounds (bds 1-24) 
 
1.4 Scoring 

 The program allows for 4 scoring methods: - 
 Normal Swiss Pairs with results reported in VPs 
 Butler VPs 
 Butler IMPs 
 Swiss Percents with scores reported in %s 

 Score input can either be manual or via bridgemates 
 Assignments can be either Current Round or Round Behind 

At any time, it is possible to change the score input method.  If a problem were to develop with the 
bridgemates then you can switch to manual input of scores– reassuring! 
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1.5 Stationary Pairs 
Stationary pairs (or Sitters as the program describes them) can be fixed at any table at the start of the 
event and in subsequent rounds are drawn against their correct opponents according to their position 
in the ranking list. 
If a stationary pair is performing in such a way that their seated table does not reflect their true 
position in the event, then their fixed table can be re-assigned at a suitable juncture (e.g., start of a 
new session, after meal break). 
 
1.6 Draw Algorithm 
Normal rules apply – by ranking, taking into account previous opponents.  If pairs are tied in the 
ranking list they are arranged in descending Swiss Points order for next round draw purposes.  It is 
also possible to do a Danish draw at any time (assignments in strict ranking with no account taken of 
previous opponents). 
 
1.7 Bridgemates 
With only one section the bridgemates are set up as A1 upwards.  If set up as more than one section, 
bridgemates need to be set up as A1…, B1… etc. 
If set up as one section spread over two or more playing areas via a LAN it is advisable for each area 
to work with a different channel. 
 
In the description that follows of how to use of the program I have described how to set 
up and run a single section, multi-session event (3 sessions each of 3 rounds with 6 
boards/round), with Current Round Scoring, using bridgemates scoring in %s. 
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2. USING THE PROGRAM 
 
When you start Swiss Pairs Scorer you are presented with the Main Menu. 
 
2.1 Names Database 
Main Menu > Update Membership > Club Membership screen. 
From here it is possible to add names to the database.  Names can be typed in as <First name> 
<Surname> click Add New Member.  Alternatively names can be imported as a csv file – click 
Import Player Listing and follow the on-screen instructions. 
Players can be assigned a short name or tag of up to 4 characters and their NBO Number, either of 
which can be used when entering the names for an event. 
Clicking on Return takes you back to the Main Menu. 
 
2.2 Creating an Event 
Main Menu > Swiss Pairs Scorer > Event History > Create New Event > Event setup screen 

 
Club Details  Enter Club Name, Country and other details as appropriate. 

Event Details  Date is automatic.  Enter Event Name. 

Scoring Method  Swiss Pairs for VP scoring, Swiss Percents to score in %s.  

Matchpoint in Sections With only 1 section, this can be ticked or unticked.  With multiple sections 
which are scored across the field, untick.  With multiple sections that are 
scored and drawn as independent sub-fields, tick  

Master points  As appropriate 

Movement  Click in Session 1 box and enter the rounds for that session.  Repeat for any 
other sessions.  Input the section(s) details and finally, enter the boards per 
round. 

 
All details in > OK > Message Appears > OK > Event screen > click Return > Event History screen 
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The program has created three “Events”, one for each session. 

 

If the event is multi-session (as in the example above) or multi-section you must create a Master 
Control Event. 

Click on the first component event, hold down the <Shift> key and click on the last component event 
- all the component events should now be highlighted. 

If the overall event is multi-session > click on Combine Sessions > Yes > OK 
If the overall event is single session > click on Merge Sections > Yes > OK. 

The program now creates a new “event” with a section description of “Multi” – this is the Master 
Control event. 

If your event is single section, single session event there is no need to create a multi-event. 

If you have created a multi-event, click on that event then Retrieve Event.  If single section, single 
session, click on that event then Retrieve Event > OK > Event screen. 
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2.3 Entering Names 
Names can be entered before the event or left till the event has actually started.  Names > 

 
 

Names can be entered by typing them in full, typing the 4 character code if you have set this up, the 
NBO Number or by selecting the name from the database by clicking on it.  The list on display can be 
reduced by clicking on the appropriate letter at the bottom of the screen – only surnames starting with 
that letter then appear in the left-hand screen. 

To delete a name you have entered, click on that cell and press the <Del> key. 

If time is short, you could save time at the start by only entering Player 1 for each pair and then 
completing the rest of the names later in the event. 
When finished > OK > Event Screen. 

It is also possible to cut & paste names that have been entered; left click to select name, right click to 
cut, left click on destination cell, right-click to paste. 

Another way of entering the names is to import them from a csv file prepared in the format shown 
below: - 
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2.4 Finalising the Event 
From the Event screen > Assignments > Assignment screen: - 

 
 
2.4.1 Missing Pairs 
If pairs leave any they can be removed from the event by clicking on their pair number in the Set 
Missing Pairs, Present Column.  The pair number moves to the Missing column. 

 
2.4.2 Stationary Pairs 
To designate a stationary pair, click on the pair number in the Mover column and then on the table 
you wish to fix them at – the pair moves across to the Sitter column.  The table they are fixed at can 
be changed at a suitable juncture (meal break, start of new session) during the event.  Click on the pair 
in the Sitter column, draw the next round, and then fix the pair at the newly assigned table.  
 
2.4.3 Draw for Round 1 
In the Assign Type section, ensure that Over all Sections is selected.  Select the Assignment Method -
Current Round or Round In Arrears (if round behind, the move for round 2 is EW up one table). 
 
When everything is set, click Do Round 1 Draw > OK. 
Pairs are assigned with pair 1 vs pair 2 etc..  The Movement data can be checked by clicking Show 
Movement Information > text file appears > Close to exit the report.  To close the Assignment screen 
click on Return > Event screen. 
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3. REPORTS 
Reports are accessed from the Event screen by clicking Display Results: - 

 
A wide range of reports are available in a variety of formats.  If you choose Screen, CSV, XLS or 
HTM the report is displayed on screen in the selected format (Screen = TXT) and a copy saved in the 
Reports folder in the SwissPairsScorer folder. 

Clicking on Set Print Properties opens the Printing Properties screen where you can set the font, font 
size, orientation and for some reports the number of entries per page.  You can also specify which 
printer to use from those installed in your Printers Folder.  To leave the Printing Properties screen 
click Return.  If you wish to print a report, select Output to Printer and then click Print. 

DEFAULT PRINT PROPERTIES for A4 (Laser Printer) – 6 board rounds 
Ranks   Courier New 11, Portrait, All per page (~58 per page) 

Match Scores  Courier New 10; Portrait; 12 rows per page 

Check Slips  Courier New 9; Landscape, 5 rows per page (change to 4 if Round Behind) 

Table Scores  Courier New 9; Landscape, 4 rows per page 

Travellers  Courier New 9;  Landscape; 2 rows per page 

Frequencies  Courier New 11; Landscape; 1 row per page 

Pairs List  Courier New 11; Landscape (~40 tables per page) 

Assignments  Courier New 10; Portrait; 30 per page 

Movement  Courier New 11; Portrait; (8 rows of 5 tables per page) 

Pair History  Courier New 10; Portrait 

The above settings may have to be adjusted to obtain the best results depending on the number 
of pairs, number of boards/match, Current or Round in Arrears and the printer in use. 
To leave the Display/Print screen, click Return > Event Menu. 
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4. ROUND 1 SCORES 
From the Event screen > Bridgemate Scoring 

 
Before doing anything on this screen make sure that BMPro and all the bridgemates are set up 
correctly.  Personally I prefer to set up the bridgemate preferences via BMPro (Tools > Options > 
Bridgemate tab) with no Previous Results, Show % Own Result selected, Show pair numbers at 
round info selected and no Board Order Verification. 
However, you can set the bridgemate preferences by clicking BMPro Settings – this will override any 
settings in BMPro. 

Ensure Session = 1 & Section = All (or A) are selected in the menu boxes (near top of screen). 

Click Create Database > OK. Bws file is created in SwissPairsScorer folder. 

Ensure that Restart Server is ticked 

Click Start BMPro > Yes BMPro opens and tables are added to the server.  Minimise BMPro. 

Display above then changes so that only the Session 1 rounds are shown. 

Click Start Receiving  Imports scores from bws file to the scoring program. 

If you leave this screen to do something else (enter names) then you have to click on Start Retrieving. 

Progress during the event can be monitored using either BMPro or the Bridgemate Scoring screen.  
For Section A, Round 1, the display indicates that it is expecting 480 scores.  Rx is the total scores 
received from the Section A tables to date.  The number of scores received from individual tables is 
shown under the appropriate table column.  Clicking on Missing Scores will provide details of scores 
that have still to come in.  Current Ranks or Match Scores can be displayed on screen by clicking the 
appropriate buttons. 

DO NOT BE TEMPTED TO CLICK ON RESTART 

This is for use only if BMPro crashes or is closed down inadvertently (see section 11.3) 

Once all the scores are in for Round 1, click Return > Event screen > Assignments 
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The Assignments screen will now indicate (top left-hand corner) the Last Completed Round.  The 
Current Movement State will indicate the current progress of the event (if there are still outstanding 
scores, this will be indicated here). 
See Sections 9 and 10 for score amendments and special operations on the next round draw. 
 
 
5. ROUND 2 DRAW 
If any changes are required to Sitters or Missing Pairs this should be done before drawing the next 
round.  Ensure that Overall All Sections and Current Round are selected. 

Click Do Round 2 Draw > OK > Return > Event screen > Display Results 

If having made the draw you then realise that you have made a mistake re Sitters, or Missing Pairs, 
make the change then re-click Do Round 2 Draw > OK > Return > Event screen > Display Results. 
 
 
6. REPORTS 
6.1 Assignments for Next Round 
To print the Round 2 assignments, select Round 2 (drop-down list), select Assignments & Printer, 
click Display.   
 
6.2 Rankings 
To print ranking after Round 1, select Round 1 in the drop-down list, select Rankings & Printer and 
click Print.  The option is there to also print previous round scores, etc.  If scoring %s current running 
% total is shown to 2 decimal places; previous round scores are shown to zero decimal places. 
 
6.3 Table Check Slips 
Normally, you would print the table check slips for the round just ended once the draw for the next 
round has been made; eg, assign for round 2 and then print round 1 check slips.  This way the slips 
have the pairs at their assigned table in round 2. 
Occasionally at the end of a session or the end of the event you may wish to print the check slips 
before the next round has been drawn – in which case, select Last assigned Round Override. 

The body of these reports shows the scores and match point awards for each board, total match points 
for the round and the VP score (or the % score for the round to 2 decimal places).  Just above that, top 
on a board and max match point award for a round is given.  If scoring in %s all previous round %s 
are shown to zero decimal places.  Near the top, the pair’s current overall score (or % score to 2 
decimal places) is displayed. 

If the option to display Ranks and leading score has been selected, the pair’s current rank and the 
leading score are shown (with %s, the leading score is to two decimal places). 

If the option Not Collated for Printed had no tick, then the check-slips are printed with table 1 at the 
top of page 1, table 2 at the top of page 2 … Then, if you have a powerful enough guillotine the whole 
stack of check-slips can be sliced to give 4 or 5 piles with the tables in numerical order. 

If the option Not Collated for Printed had been ticked, the check-slips would be printed out with, for 
example, tables 1-4 on page 1, 5-8 on page 2 … 
 
When printouts are complete, click Return > Event screen > Bridgemate Scoring. 
 
 
7. ROUND 2  
Bridgemate Scoring screen  Click Update Database > Yes > OK.   Restart Server NOT ticked 
The program creates a copy of the bws file prior to the round 2 movement data being added to it.  This 
copy of the bws file is stored in the Backups folder within SwissPairsScorer.  Unless you rename the 
backup bws file it will be over-written at the start of subsequent rounds. 
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BMPro Report re Movement Update > Close > minimise BMPro 

Click Start receiving. 
 
Thereafter, the procedure for Round 2 and subsequent rounds is simply a repeat of the procedures 
described above for rounds 1 & 2. 
 
If the event is a single session event, simply continue till the last round of the event has been played 
and scored.  See below for Multi-session events 
 
 
6. SESSION 2 (and the start of any subsequent sessions) 
Once all the scores are in for the last round of Session 1 > Return to get to Event Menu > Return > 
Event History screen. 
Close BMPro via File > Close > File > Exit 
From the Event History screen, select the “Multi” Section (Master Control Event) > Retrieve Event > 
Yes > Event Details screen > Assignments > Do round x Draw (for first round of new session; round 
numbers are carried forward from session 1) > Return > Event screen > Display Results and print out 
the assignments for the next round (and the current ranking/check-slips if required). 

When you are ready to actually start the first round of the new session, navigate to the Bridgemate 
Scoring screen and ensure that the new session number is displayed (near top of screen) 

Click Create Database > OK; ensure Restart server is ticked then click Start BMPro > Yes. 
BMPro opens and tables are added to the server.  Minimise BMPro. 
Click Start Receiving and continue as before. 
 
 
7. END OF EVENT 
After the last round of the event has been played print table check-slips for the last round by selecting  
The Last Assigned Round Override option. 
Once the final rankings have been published, it is worthwhile making csv files of the various reports, 
setting Round to All: Ranks +Round Scores; Match Scores, Table Scores & Pairs History. 
Once the reports have been created (in the Reports folder in the SwissPairsScorer folder move them to 
another folder (e.g. Event Oct08).  The Ranks +Round Scores will supply the Master Points Secretary 
with all the information required and the same file can also be sent to the webmaster.  The other 
reports many be useful in settling any queries in the period following the event. 

Another possibility is to copy or move the data files (STBoards.dat, STEvents.dat & STContracts) 
into another appropriately named folder.  If moved, the program re-creates new data files next time it 
is opened 
 
 
8. FILE HOUSEKEEPING 
As long as you have kept csv files or the dat files (see section 7), it is advisable to clear out old event 
files so that you start each new event with an empty Event History screen. 

To delete all the files for an event you must first delete the multi section Control Master Event (Multi) 
– select this event and then click Delete Event.  Then click on the first of the component event files, 
hold down the Shift key and click on the last of the component event files - they should all be 
highlighted.  Click Delete Event.  The program will ask you for confirmation – hold down the 
<Return> key and all the component files will be deleted one after the other. 
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9. SCORE ADJUSTMENTS  
Any score amendments or adjustments are best left until all the scores for that round have been 
received.  Click Return until you arrive at the Event screen and then click Enter Scores. 

 
 
Using the boxes at the top of the screen, navigate to the correct Session, Section, Table and Round. 
To delete a current score, click in the box in the column under the NS & EW Pair numbers 
corresponding to the board number and press the ‘D’ key (case does not matter) – the score is deleted. 
9.1 Replacing one score with a different score 
Click in the box and either enter the score as e.g. 10+ or 9- <Enter>.  Alternatively, if so inclined, you 
could click Score by Contract and enter the contract details according to the format displayed on the 
screen followed by <Enter> 
9.2 Replacing a score with an Arbitral score. 
Click in the box and enter the score as 50/50, 40/60 etc. followed by <Enter> 
9.3 Split Score 
Using the Weighted Scores box enter the details of both scores. 
See example opposite where NS score +420 and EW +50. 
Note that the EW score is entered relative to NS. 
Then click box in the score column and press the ‘W’ key. 
Click on Return > Event screen > Display Results > select Table Scores 
for that round and examine the details for that table to check that the VP 
scores for the match do not balance. 
 
9.4) Other Adjustments 
Adjustments for whatever reason can be entered as follows 
Click Return to get to the Event screen > Adjustments + Categories 
Click on the Adjust Column corresponding to pair, add the value of the adjustment and category, if 
required, OK to exit to Event screen. 
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10. SPECIAL DRAW OPERATIONS 
 
10.1 Danish Draw  
If the ratio of pairs to rounds is too low then towards the end of an event the normal draw may 
become distorted with pairs at the top of the ranking being assigned against pairs who were well down 
the ranking.  This can be overcome by selecting Danish Draw in the Assignments screen.  A Danish 
Draw simply assigns pairs in strict order of ranking taking no account whatsoever of any previous 
meetings, so that pairs may play a match against a pair they have already played. 
 
10.2 Pairs sit at Wrong Tables 
If this happens after the round has started, best approach is to do 
nothing until all the scores for the round are in. 
Navigate to the Assignments screen. 
Ensure that the correct round is selected in the drop-down list 
For example, let’s say that pair 80 sat at Table A5 and pair 27 at A4.  
Click on the cell with pair 80 at A4 and press <delete> key.  Then 
type 27 in the cell <Enter>.  Repeat for pair 27 at A5; replacing them 
with 80. 
Click Set Manual Assignments > Yes. 
 
Similarly, if 2 pairs sit at the correct tables but in the wrong 
directions.  For example, at Table A3, the pairs sit with pair 125 as 
NS & pair 113 as EW.  At the end of the round manually adjust the 
draw as described above   

Any other manual adjustments can be done in the same manner. 
 
Another way to correct this is to type 'A' for every score at the table in the Enter Scores screen see 
Section 9).  This arrow-switches the NS/EW Pair on each board.  The Arrow switch should be 
reflected in the Match scores, Travellers & Table scores. 
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11. COMPUTER PROGRAM PROBLEMS 
 
11.1  General Guidance 
You should not panic! Most problems can easily be resolved in the Scorer using the Create Database 
and Start BMPro command and the Scoring may be resumed with virtually no disruption. 
 
Create Database Command 
 
Normally the Scorer sets up a new Movement using this command. In a recovery situation, when 
you are informed that the Database already exists, you must answer ‘No’ so that the Database 
will not be recreated. (As contingency, if a Database already exists, then it will be backed up in the 
Backups folder before the new one is recreated).  
 
Start BMPro Command 
 
Normally the Scorer Starts BMPro with Reset Server ticked. This clears out the Server Data and thus 
will direct the Movement to the Start of play. In a recovery situation, you must ensure Reset 
Server is not ticked so that the Server will continue from where it was in the movement.  If you 
do tick Reset Server, then the server loses all its data. This means that the Bridgemates now think they 
are at the start of the event and are looking for scores for round 1 (even boards that have already been 
entered).  Even if you do tick Reset Server, you can still largely recover by restoring the server to the 
position when the computer fail occurred. This is done by: 
 
BM Pro Menu Bar > Session > Synchronise client-server > Recovery Tab 
Click Recover Server. Message appears: 
 

 
 
Click > Yes; another message appears: - 

 
 
 
 
 
 
 

 
Click > Yes 

Enter number shown > OK 
 
Report appears regarding scores updates > close. 
 
Bridgemates will still be red; press OK on bridgemates till they appear in green and you are back 
where you were when computer closed down. 
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11.2   General Recovery Procedure 
 
1   Close down Scorer and BMPro 

A. Load BMPro 
B. Open the appropriate .bws file 

2   Retrieve the Event that you were using before the problem occurred  
3   Click the ‘Bridgemate Scoring’ 
4   Click ‘Create Database’ (Ref 13.1). In reply to the ‘movement already exists’ message, reply N. 
5   ‘Start BMPro’ with Reset Server unticked 
6   Wait for all the tables to be added 
7   ‘Start Receiving’ data as normal again. 
 
The system should be back and operating as before. If a table has entered results when the computer 
was down, they are lost during the recover server process and will have to be re-entered into the 
Bridgemates. Check on the Scorer’s Bridgemate control screen for any outstanding scores for the 
current round and advise any tables with missing scores to re-enter them on the bridgemates. 

 
11.3  Computer Freezes or Closes Down During an event 
 
The biggest problem when a Computer freezes is that it cannot be closed down using any of the 
normal Windows methods (File  Exit, Alt+F4 etc). To get round this Press Ctrl + Alt + Del.  This 
will bring up the Windows Task Manager.  Select the program (often there will be a note beside it 
saying that it is not responding) and click on End Task.  The program should then close down.  If the 
Windows Task Manager cannot be invoked, then you should close down the computer by holding the 
power key/button down for 5-10 seconds. Adopt the General Recovery procedure (Ref 11.2). 
 
11.4  Computer Closes Down During an event 
 
A common cause is the Laptop has gone into Standby (hibernate mode) after no key has been pressed 
for a certain time. It is best at start to set the Power Options in Control Panel to avoid this. However, 
as long as the Bridgemate Server retains power (mains or battery) it will retain all the data it had 
before the crash as well as any results sent from the Bridgemates while the computer was down. 
Adopt the General Recovery scheme (Ref 11.2). 
 
11.5  Bridgemate Control Program Inadvertently Closed 
 
BMPro has been (accidentally) closed in the middle of a Session. The Scorer and the Server are still 
running and operating in the normal way. Adopt the General Recovery scheme (Ref 11.2). 
 
11.6  Scorer Inadvertently Closed 
The Scorer has been closed in the middle of a Session even though the the BMPro controller is still 
running and the Server is still operating normally. Adopt the General Recovery procedure (Ref 11.2) 
 
11.7  Only see ‘Loading’ Message when Scrolling Results 
In Internet Explorer choose the Tools menu, then Internet Options. 
Click the Advanced tab and Scroll down to the Security Section. 
Tick the box "Allow Active Content to run in files in My Computer".  
Click OK  
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12. BRIDGEMATE PROBLEMS 
 
The procedures described below are for emergency use only and assume that all normal methods of 
recovering from bridgemate problems have been tried & failed. 
 
12.1 Problems with a Small Number of Bridgemates 
Issue the affected tables with travellers (Swiss Pairs type table score sheets are best) so that they can 
record the scores at the table. 
To enter the scores for these tables, navigate to the Event screen > Enter Scores 

 
Using the drop-down boxes at the top of the screen, navigate to the appropriate Session, Section, 
Table and Round. 
 
Scores are entered in the column of cells under the Pair numbers.  Click in the first cell and enter 
scores as e.g., 9+, 12- etc.  The +/- moves the cursor to the next board. 
Once all the scores for the affected tables have been entered, click Return. 
 
12.2 Major problem with All (or most) of the Bridgemates. 
If a problem of this scale occurs it is most likely to happen when the movement information for a new 
round is being sent to the server.  But it could happen during a round. 
In such circumstances the best solution is to abandon scoring using bridgemates and revert to the 
traditional method of manually entering scores from table score sheets. 
 
To switch to manual scoring, click Return till you get to the Event screen, then click Enter Scores.   
 
All other program operations (assignments, adjustments, print-outs) are identical to the procedures 
described for scoring with bridgemates. 
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13. MULTI-SECTION EVENT: SECTIONS SCORED SEPARATELY 
 
If the location of the event is such that it has to be held in two (or more) playing areas and it is not 
practicable to have complete draws across the entire field, the program allows the two playing areas to 
be played & scored as separate sub-fields.  At the start of each session an overall draw is made and 
thereafter during each session the draws are made within sections. 
Each laptop must have BMPro and the same version of Swiss Pairs Scorer installed. 
The process is described below in outline. 
 
For the purpose of this illustration, assume we have two playing areas (area 1 and area 2) with section 
A in area 1 and B in area 2. 
Area 1 
Laptop 1 which also acts as the master laptop; bridgemates set up as A on Ch 1; server on Ch1 
Area 2 
Laptop 2; bridgemates set up as B on Ch 2; server on Ch 2  
 
Before starting it is strongly advisable to delete any old event files on both laptops 
 
Session 1 
Create the event on laptop 1 and do draw for round 1 Across All Sections. 
From the SwissPairsScorer folder copy the files SPBoards.dat, SPEvents.dat & SPContracts onto a 
memory stick.  Copy the files from the memory stick into the SwissPairsScorer folder on laptop 2. 
On both laptops the multi event is used to control the event. 
 
When ready to start round 1, ensure the correct section has been chosen on the Bridgemate Scoring 
screen before creating the database (the bws file on each laptop will contain all the tables which are 
part of the multi event).  When BMPro is started the correct tables are then sent to each of the servers. 
 
Once all the results from an area are in, the draw for the next round can be made.  Ignore any 
warnings about outstanding scores and draw round Within Sections. 
When printing any reports remember to select the correct sections; A, B etc. 
 
End of Session 1 
Laptop 2 – close SwissPairsScorer & BMPro and copy SPBoards.dat, SPEvents.dat & SPContracts 
from the SwissPairssScorer folder onto a memory stick. 
Laptop 1 – Close BMPro and click Return till you get to the Main Menu then select Import Event. 
Click on Set Folder Containing Selected Event Files then browse to the Memory stick drive – the 
event files from laptop 2 will appear in the left-hand pane (multi event does not appear). 
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What you have to do now is to import the event files for the sections in area 2 (B) into 
SwissPairssScorer on laptop 1. 
Click on Section B; Session 1 in the left hand pane; then click on Section B; Session 1 in the right-
hand then click on Replace Event in Current Events > Yes > OK. 
This procedure overwrites the Section B draw & result data in laptop 1 so that this laptop now has the 
complete data for all sections. 
 
When the import is complete click on Return > Main Menu. 
To pick up the merged data: Swiss Pairs Scorer > Retrieve the Multi file > Event Menu. 
Note: 
If a pair were to withdraw during a session in area 2 this is not picked up during the above file transfer 
process.  Navigate to the Assignments and mark that pair as Missing 
 
To print out the overall rankings, go the Display Results > Ranking making sure that All is selected in 
the Section box. 
 
Session 2 
The draw for the first round of Session 2 is performed on laptop 1; Across All Sections 
Thereafter, proceed as described for Session 1. 
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14. MULTI-AREA EVENT: NETWORKED 
 
If it is possible to link the different playing areas through a LAN then it should be possible for pairs to 
move between the different areas so that the event can be run as single section (A) event with all new 
round draw made across the field (i.e., draws made Across All Sections). 
 
The master laptop needs to have BMPro and SwissPairsScorer installed; the other laptops only require 
BMPro. 
Bridgemates in each section are set as Ax with each area operating on a different channel. 
 
Session 1 
Set up the event as normal on the master laptop and carry out round 1 draw.  Navigate to the 
Bridgemate Scoring screen, ensure Session = 1 and Section = All,  Restart server is ticked then 
Create Database followed by Start BMPro.   
 
Once the bws file has been created, and the movement data sent to the server in area 1, the other 
laptops can then pick up the bws file (Event1-Sess1.bws) and add their tables to their server. 
On each of the other laptops: - 
Start BMPro, then File > Open > browse over the network to the bws file on the master laptop >Open 
 
This computer has not logged on before to this session.  Log on Now > Yes 
 
On the All Tables tab select all the tables in that area > Right-click > Add to Client > Yes 
 
On the Client Tables tab > right-click > Select All > Add to Server 
 
Report from BMPro > Close 
 
Round 1 
Event progress in the outlying areas can be monitored via BMPro 
 
As results come into the servers in the outlying areas they are transferred to the bws file on the master 
laptop. 
Once all the tables in an area have completed round 1, leave BMPro maximised. 
 
Once all the results from all areas have been received on the master laptop, the draw for round 2 can 
be made Across All Sections. 
Then navigate to the Bridgemate Scoring screen and Update Database. 
Once the new movement data has been received on each laptop, BMPro will produce a report > Close 
 
Any reports that are required can now be printed out on the master laptop. 
 
Thereafter proceed for round 2 & subsequent rounds in session 1 as described under Round 1 above. 
  
Event is Multi-session. 
Once the last round of the session is complete, reset server in BMPro: Server > Reset and follow the 
on-screen prompts. 
The draw for the first round of session 2 is created on the master laptop following the procedure 
described above for Session 1, except that Session = 2 and Sections = All must be selected before 
Create Database. 
The new bws file (Event1-Sess2.bws) will be created.  Ensure that Restart server is ticked and 
proceed as described above under Session 1 and Round 1. 


